RM> # HG changeset patch
RM> # User Richard Maciel <richardm(a)br.ibm.com>
RM> # Date 1224109379 25200
RM> # Node ID e71c0941849da4338ed56d784a6c3966b73ffaf7
RM> # Parent 5f835a32ab3aa0dc26718371c3f4a0a0abe879ae
RM> Signed-off-by: Richard Maciel <richardm(a)br.ibm.com>
Your DCO is typically the last line of the commit log, otherwise it
shows up as the short description (and subject line) of the patch.
RM> * Added association Console Redirections Service <-> Console Redirection
Service
RM> Capabilities into the ElementCapabilities.c file
RM> * Added ConsoleRedirectionServiceCapabilities.h to export the get_console_rs_caps
function
RM> * get_console_rs_caps is not static anymore
If you could wrap your commit log at 80 characters, it would help
readability.
RM> - -lVirt_DevicePool
RM> + -lVirt_DevicePool \
RM> + -lVirt_ConsoleRedirectionService \
RM> +
-lVirt_ConsoleRedirectionServiceCapabilities
Looks like you've got some mixed whitespace here.
RM> -static CMPIStatus get_console_rs_caps(const CMPIBroker *broker,
RM> +/* Removed the static keyword from the function declaration to
RM> + * make it available for other modules */
RM> +CMPIStatus get_console_rs_caps(const CMPIBroker *broker,
RM> const CMPIObjectPath *ref,
RM> CMPIInstance **_inst,
RM> bool is_get_inst)
The comment is not necessary. Also, please realign the parameter list
after removing the static.
RM> - } else
RM> + } else if (STREQC(classname,
"ConsoleRedirectionServiceCapabilities")) {
RM> + s = get_console_rs_caps(_BROKER, ref, &_inst, true);
RM> +
RM> + if((s.rc != CMPI_RC_OK) || (_inst == NULL))
You're using tabs instead of spaces on these (and all) new lines. The
coding standard for libvirt-cim is 8 spaces.
You also need a space between your 'if' and '('.
See doc/CodingStyle for this and other things.
RM> -
RM> + CU_DEBUG("After class_base_name\n: %s", classname);
This debug statement is probably not generally useful.
RM> + } else if(STREQC(classname, "ConsoleRedirectionService")) {
RM> + CU_DEBUG("before console_rs\n");
This one can be removed as well.
RM> + s = get_console_rs(ref, &_inst, _BROKER, context, true);
RM> + if((s.rc != CMPI_RC_OK) || (_inst == NULL))
RM> + goto out;
RM> +
RM> + CU_DEBUG("before console_rs_caps\n");
This one too.
RM> + s = get_console_rs_caps(_BROKER, ref, &_inst, false);
RM> + if((s.rc != CMPI_RC_OK) || (_inst == NULL))
RM> + goto out;
RM> + CU_DEBUG("after console_rs_Caps\n");
...and this one.
RM> + CU_DEBUG("service_to_cap\n");
...and this one :)
Thanks!
--
Dan Smith
IBM Linux Technology Center
Open Hypervisor Team
email: danms(a)us.ibm.com