Tried with commenting out cgroup_controllers but with no change.

Tried also unmounting /sys/fs/cgroup and mount the cgroups in a subfolder hierarchy manually but it remounted still all together (I think this is related at the unmounting support going away, I'm with kernel 3.10-rc4 on the test machine).

So I had a look at Slackware's init system's scripts: /sys/fs/cgroup is mounted in /etc/rc.d/rc.S, the main one, so I tried changed it to automount in subfolders the available controllers

--- ./etc/rc.d/rc.S.orig        2012-09-13 21:38:34.000000000 +0200
+++ ./etc/rc.d/rc.S     2013-06-07 19:56:06.176366278 +0200
@@ -51,7 +51,14 @@
 # Mount Control Groups filesystem interface:
 if grep -wq cgroup /proc/filesystems ; then
   if [ -d /sys/fs/cgroup ]; then
-    mount -t cgroup cgroup /sys/fs/cgroup
+    # Mount a tmpfs as the cgroup filesystem root
+    /sbin/mount -t tmpfs cgroup_root /sys/fs/cgroup
+    # Mount individual cgroup controllers:
+    controllers="$(/usr/bin/lssubsys -a 2>/dev/null | tr '\n' ' ' | /usr/bin/sed s/.$//)"
+    for i in $controllers; do
+      /usr/bin/mkdir /sys/fs/cgroup/$i
+      /sbin/mount -t cgroup -o $i $i /sys/fs/cgroup/$i
+    done
     mkdir -p /dev/cgroup
     mount -t cgroup cgroup /dev/cgroup

This way virtual machines start fine, thanks a lot Daniel :)