Sorry, I will keep the instructions in mind.

I tried ./autogen.sh with --system but there was a version mismatch.
I guess someone should write a patch for debian based system. 

tried to install libvirt 1.1.1 with Fedora and when I did make, I got the
following error:

 Making all in src
make[2]: Entering directory `/home/peeyush/Downloads/libvirt-1.1.1/src'
  GEN      libvirt_access_lxc.syms
/bin/sh: -w: command not found
make[2]: *** [libvirt_access_lxc.syms] Error 127
make[2]: Leaving directory `/home/peeyush/Downloads/libvirt-1.1.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/peeyush/Downloads/libvirt-1.1.1'
make: *** [all] Error 2

Any idea why am I getting this?

~Peeyush Gupta

From: Eric Blake <eblake@redhat.com>
To: Peeyush Gupta <gpeeyush@ymail.com>
Cc: "libvirt-users@redhat.com" <libvirt-users@redhat.com>
Sent: Wednesday, 31 July 2013 6:19 PM
Subject: Re: [libvirt-users] Installing libvirt

On 07/30/2013 11:30 PM, Peeyush Gupta wrote:
> Hi,

[can you convince your mailer to wrap long lines?  Also, it looks like
your mailer is not using proper in-reply-to headers, such that you are
spawning a new thread every time you reply]

> I am trying to install new libvirt version on Ubuntu 12.04 LTS. Now I downloaded libvirt 1.0.5 from libvirt.org/sources then I issued three commands:

Any reason you went with 1.0.5 instead of the just-released 1.1.1?

> ./autogen.sh

> This installs the libvirt on my system. But there are some issues, I have to run libvirtd explicitly everytime

This defaults into installing things into /usr/local, which does not
match the paths your distro normally uses.  Your problems may stem from
the fact that because you didn't install it into distro locations, your
distro is unable to run libvirtd as a service.  If you run './autogen.sh
--system', that helps prepopulate the configure options such as --bindir
that are more likely to match your distro layout (I know for sure that
./autogen.sh --system matches Fedora layout, but don't know if
Debian-based layout differs, although no one has written a patch
complaining otherwise).

Eric Blake  eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org