Hi Daniel,

Thanks for the reply.  I realised that I am looking for my problem in the wrong place.  I was making changes to the ACPI tables in seabios and then when they didn't appear in the guest acpidump I assumed that the default bios was still being used.  I realised by getting an error with an erroneous bios file path that my patched bios was being loaded, but recently qemu changes now ignore the seabios acpitables and use ones that are set up in qemu.

Thanks for your help!


On 29 July 2015 at 16:00, Daniel P. Berrange <berrange@redhat.com> wrote:
On Wed, Jul 29, 2015 at 03:40:23PM +0100, Phil Tooley wrote:
> Hello all,
> So I am trying to get a qemu guest to use a custom patched seabios image
> rather than the default /usr/share/qemu/bios.bin
> I have tried changing the domain config file to include either:
> <os>
>     --SNIP--
>     <loader readonly='yes'
> type='rom'>/home/telemin/qemu/seabios_patched.bin</loader>
> </os>

This one is correct approach - what exactly failed when you tried
this ?

> domain type='kvm' xmlns:qemu='http://libvirt.org/schemas/domain/qemu/1.0'
> --SNIP--
>   <qemu:commandline>
>     <qemu:arg value='-smbios'/>
>     <qemu:arg value='file=/home/telemin/qemu/seabios_patched.bin'/>
>   </qemu:commandline>
> --SNIP--

This is wrong '-smbios' is for setting up guest data tables,
not for providing firmware images.

|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|