Hi I am trying to add a virtualbox domain to my virsh installation, I get:

 error: Failed to define domain from Ondria.xml >>https://gist.github.com/jztech101/5aeebb82412c1910dc1f << error: internal error: unexpected domain type vbox, expecting one of these: qemu, kqemu, kvm, xen.

 virsh is compiled with VirtualBox support so I'm confused:

Virsh -V >> Virsh command line tool of libvirt 1.2.2
See web site at http://libvirt.org/

Compiled with support for:
 Hypervisors: QEMU/KVM LXC UML Xen LibXL OpenVZ VMWare VirtualBox Test
 Networking: Remote Network Bridging Interface netcf Nwfilter VirtualPort
 Storage: Dir Disk Filesystem SCSI Multipath iSCSI LVM RBD Sheepdog
 Miscellaneous: Daemon Nodedev AppArmor Secrets Debug Readline Modular.

After some insight, I decided to run it like this instead: " virsh -c vbox:///session create Ondria.xml"
Now I get:

error: failed to connect to the hypervisor
error: internal error: unable to initialize VirtualBox driver API

So, after further insight, I ran "export VBOX_APP_HOME=/usr/lib/virtualbox" and tried again. Same error as above. (/usr/lib/virtualbox is where VBoxCPCOMC.so lies and I'm told the reason for the above error is it cannot find that file in any "normal" location. Help? It should be noted I installed VirtualBox-5.0 directly from the VBox Repo for Ubuntu 14.04LTS

Julian Zhou