于 2011年01月17日 22:41, Eric Blake 写道:
On 01/16/2011 09:39 PM, Osier Yang wrote:
> "getCompressionType" trys to throw error when invalid dump image
> format is specified, or the compression program for the specified
> image format is not available, but at the same time, it returns
> enum qemud_save_formats, as a result, upper function will think
> it was successful, and disgard to check the error, this fix makes
> changes so that it returns -1 on FAILURE, And to be consistent with
> "save", won't use "raw" as the default dump format anymore.
>
> * src/qemu/qemu_driver.c
> - rename "getCompressionType" to "getDumpType"
> - return -1 on FAILURE
>
> ---
> src/qemu/qemu_driver.c | 40 +++++++++++++++++++++++++---------------
> 1 files changed, 25 insertions(+), 15 deletions(-)
This reverts commit 1b6f13bb7002d by Hu Tao that explicitly falls back
to RAW on purpose if a compression program cannot be found. We need
more justification why we are reverting a prior patch, and consensus on
the correct behavior, before this can be applied.
This patch was to fix:
https://bugzilla.redhat.com/show_bug.cgi?id=669586
IMHO there are two choices:
1) report warning instead of error to fall back to RAW.
2) don't fall back to RAW, report error and return -1, just
as "qemudDomianSave" does.
I choosed 2).
Regards
Osier