At 04/12/2011 06:27 AM, Eric Blake Write:
Jim recently improved gnulib to catch various grammar errors
during 'make syntax-check'.
* .gnulib: Update to latest, for syntax-check improvements.
* include/libvirt/libvirt.h.in (virConnectAuthCallbackPtr): Use
cannot rather than two words.
* src/driver.c: Likewise.
* src/driver.h (VIR_SECRET_GET_VALUE_INTERNAL_CALL): Likewise.
* src/remote/remote_driver.c (initialize_gnutls): Likewise.
* src/util/pci.c (pciBindDeviceToStub): Likewise.
* src/storage/storage_backend.c (virStorageBackendCreateQemuImg):
Likewise.
(virStorageBackendUpdateVolTargetInfoFD): Avoid doubled word.
* docs/formatdomain.html.in: Likewise.
* src/qemu/qemu_process.c (qemuProcessStart): Likewise.
* cfg.mk (exclude_file_name_regexp--sc_prohibit_can_not)
(exclude_file_name_regexp--sc_prohibit_doubled_word): Exclude
existing translation problems.
---
* .gnulib 4a1579d...ca6143b (40):
> autoupdate
> maint.mk: prohibit doubled words
> maint: fix doubled-word typo in comments
> maint: remove doubled word: s/it it/it/
> maint.mk: remove useless semicolon and backslash
> stdint test: Fix compilation failure on OSF/1 with DTK compiler.
> autoupdate
> maint: remove doubled words in comments, e.g., s/a a/a/
> test-chown.h: correct a cast
> fix typo in ChangeLog entry
> getaddrinfo: Fix test for sa_len member.
> maint: change "can not" to "cannot"
> maint: change "a a" to "a"
> maint.mk: prohibit \<the the\>
> maint: fix "the the" in comment
> maint: change "can not" to "cannot"
> maint.mk: prohibit use of "can not"
> careadlinkat: Guard against misuse of careadlinkatcwd.
> careadlinkat: Use common coding style.
> careadlinkat: Clarify specification.
> areadlinkat: Avoid link error on many platforms.
> allocator, careadlinkat: Fix double-inclusion guard.
> relocatable-prog-wrapper: Update after module 'areadlink' changed.
> relocatable-prog-wrapper: Update after module 'areadlink' changed.
> strftime: silence gnulib-tool warning
> verify: Fix syntax error with GCC 4.6 in C++ mode.
> autoupdate
> allocator: New module.
> * lib/stdlib.in.h (malloc, realloc): Limit this change to a smaller scope.
> * lib/realloc.c (_GL_USE_STDLIB_ALLOC, malloc, realloc): Likewise.
> * lib/malloc.c (_GL_USE_STDLIB_ALLOC, malloc): Likewise.
> * lib/relocwrapper.c (_GL_USE_STDLIB_ALLOC, malloc): Likewise.
> * lib/relocatable.c (_GL_USE_STDLIB_ALLOC, malloc): Likewise.
> * lib/canonicalize-lgpl.c (_GL_USE_STDLIB_ALLOC, malloc): Likewise.
> * lib/setenv.c (_GL_USE_STDLIB_ALLOC, malloc, realloc): Likewise.
> * lib/progreloc.c (_GL_USE_STDLIB_ALLOC, malloc): Likewise.
> * lib/malloca.c (_GL_USE_STDLIB_ALLOC, malloc): Likewise.
> * lib/careadlinkat.c (_GL_USE_STDLIB_ALLOC): Define.
> stdlib: let modules use system malloc, realloc
> careadlinkat: rename members to avoid problem
.gnulib | 2 +-
cfg.mk | 4 ++++
docs/formatdomain.html.in | 2 +-
include/libvirt/libvirt.h.in | 2 +-
src/driver.c | 4 ++--
src/driver.h | 2 +-
src/qemu/qemu_process.c | 2 +-
src/remote/remote_driver.c | 2 +-
src/storage/storage_backend.c | 4 ++--
src/util/pci.c | 6 +++---
10 files changed, 17 insertions(+), 13 deletions(-)
diff --git a/.gnulib b/.gnulib
index 4a1579d..ca6143b 160000
--- a/.gnulib
+++ b/.gnulib
@@ -1 +1 @@
-Subproject commit 4a1579d7560659ef5723325726eda14490a967f6
+Subproject commit ca6143b425589c3a64bd28efd7af14463f96d576
diff --git a/cfg.mk b/cfg.mk
index 4ed0d96..94db937 100644
--- a/cfg.mk
+++ b/cfg.mk
@@ -573,9 +573,13 @@ exclude_file_name_regexp--sc_prohibit_always_true_header_tests = \
exclude_file_name_regexp--sc_prohibit_asprintf = \
^(bootstrap.conf$$|po/|src/util/util\.c$$|examples/domain-events/events-c/event-test\.c$$)
+exclude_file_name_regexp--sc_prohibit_can_not = ^po/
+
exclude_file_name_regexp--sc_prohibit_close = \
(\.py$$|^docs/|(src/util/files\.c|src/libvirt\.c)$$)
+exclude_file_name_regexp--sc_prohibit_doubled_word = ^po/
+
exclude_file_name_regexp--sc_prohibit_empty_lines_at_EOF = \
(^docs/api_extension/|^tests/qemuhelpdata/|\.(gif|ico|png)$$)
diff --git a/docs/formatdomain.html.in b/docs/formatdomain.html.in
index 574fee5..3c4c656 100644
--- a/docs/formatdomain.html.in
+++ b/docs/formatdomain.html.in
@@ -774,7 +774,7 @@
<span class="since">Since 0.0.3; "device" attribute
since 0.1.4;
"network" attribute since 0.8.7</span></dd>
<dt><code>source</code></dt>
- <dd>If the disk <code>type</code> is "file", then the
+ <dd>If the disk <code>type</code> is "file", then
the <code>file</code> attribute specifies the fully-qualified
path to the file holding the disk. If the disk
<code>type</code> is "block", then the
<code>dev</code>
diff --git a/include/libvirt/libvirt.h.in b/include/libvirt/libvirt.h.in
index 04b7fbf..5783303 100644
--- a/include/libvirt/libvirt.h.in
+++ b/include/libvirt/libvirt.h.in
@@ -505,7 +505,7 @@ typedef virConnectCredential *virConnectCredentialPtr;
* When authentication requires one or more interactions, this callback
* is invoked. For each interaction supplied, data must be gathered
* from the user and filled in to the 'result' and 'resultlen' fields.
- * If an interaction can not be filled, fill in NULL and 0.
+ * If an interaction cannot be filled, fill in NULL and 0.
*
* Returns 0 if all interactions were filled, or -1 upon error
*/
diff --git a/src/driver.c b/src/driver.c
index f882ea1..579c2b3 100644
--- a/src/driver.c
+++ b/src/driver.c
@@ -1,7 +1,7 @@
/*
* driver.c: Helpers for loading drivers
*
- * Copyright (C) 2006-2010 Red Hat, Inc.
+ * Copyright (C) 2006-2011 Red Hat, Inc.
*
* This library is free software; you can redistribute it and/or
* modify it under the terms of the GNU Lesser General Public
@@ -32,7 +32,7 @@
#define DEFAULT_DRIVER_DIR LIBDIR "/libvirt/connection-driver"
-/* Make sure ... INTERNAL_CALL can not be set by the caller */
+/* Make sure ... INTERNAL_CALL cannot be set by the caller */
verify((VIR_SECRET_GET_VALUE_INTERNAL_CALL &
VIR_SECRET_GET_VALUE_FLAGS_MASK) == 0);
diff --git a/src/driver.h b/src/driver.h
index e5f91ca..a8b79e6 100644
--- a/src/driver.h
+++ b/src/driver.h
@@ -1063,7 +1063,7 @@ struct _virDeviceMonitor {
enum {
/* This getValue call is inside libvirt, override the "private" flag.
- This flag can not be set by outside callers. */
+ This flag cannot be set by outside callers. */
VIR_SECRET_GET_VALUE_INTERNAL_CALL = 1 << 16
};
diff --git a/src/qemu/qemu_process.c b/src/qemu/qemu_process.c
index 9ada24d..7295f9e 100644
--- a/src/qemu/qemu_process.c
+++ b/src/qemu/qemu_process.c
@@ -2326,7 +2326,7 @@ int qemuProcessStart(virConnectPtr conn,
ret = virCommandRun(cmd, NULL);
VIR_FREE(pidfile);
- /* wait for qemu process to to show up */
+ /* wait for qemu process to show up */
if (ret == 0) {
if (virFileReadPid(driver->stateDir, vm->def->name, &vm->pid))
{
qemuReportError(VIR_ERR_INTERNAL_ERROR,
diff --git a/src/remote/remote_driver.c b/src/remote/remote_driver.c
index 9310ddf..5cb4f4c 100644
--- a/src/remote/remote_driver.c
+++ b/src/remote/remote_driver.c
@@ -1223,7 +1223,7 @@ initialize_gnutls(char *pkipath, int flags)
goto out_of_memory;
/* Use default location as long as one of CA certificate,
- * client key, and client certificate can not be found in
+ * client key, and client certificate cannot be found in
* $HOME/.pki/libvirt, we don't want to make user confused
* with one file is here, the other is there.
*/
diff --git a/src/storage/storage_backend.c b/src/storage/storage_backend.c
index 8af2878..97a7e4b 100644
--- a/src/storage/storage_backend.c
+++ b/src/storage/storage_backend.c
@@ -703,7 +703,7 @@ virStorageBackendCreateQemuImg(virConnectPtr conn,
(!inputBackingPath ||
STRNEQ(inputBackingPath, vol->backingStore.path))) {
virStorageReportError(VIR_ERR_INTERNAL_ERROR,
- "%s", _("a different backing store can
not "
+ "%s", _("a different backing store
cannot "
"be specified."));
return -1;
}
@@ -1188,7 +1188,7 @@ virStorageBackendUpdateVolTargetInfoFD(virStorageVolTargetPtr
target,
*capacity = sb.st_size;
} else {
off_t end;
- /* XXX this is POSIX compliant, but doesn't work for for CHAR files,
+ /* XXX this is POSIX compliant, but doesn't work for CHAR files,
* only BLOCK. There is a Linux specific ioctl() for getting
* size of both CHAR / BLOCK devices we should check for in
* configure
diff --git a/src/util/pci.c b/src/util/pci.c
index 248afd3..ff950d1 100644
--- a/src/util/pci.c
+++ b/src/util/pci.c
@@ -1,5 +1,5 @@
/*
- * Copyright (C) 2009-2010 Red Hat, Inc.
+ * Copyright (C) 2009-2011 Red Hat, Inc.
*
* This library is free software; you can redistribute it and/or
* modify it under the terms of the GNU Lesser General Public
@@ -1073,7 +1073,7 @@ remove_id:
* ID table so that 'drivers_probe' works below.
*/
if (pciDriverFile(&path, driver, "remove_id") < 0) {
- /* We do not remove PCI ID from pci-stub, and we can not reprobe it */
+ /* We do not remove PCI ID from pci-stub, and we cannot reprobe it */
Sorry for my bad english.
I only modify the grammar errors in error messages, and do not notice the comment.
if (dev->reprobe) {
VIR_WARN("Could not remove PCI ID '%s' from %s, and the device
"
"cannot be probed again.", dev->id, driver);
@@ -1087,7 +1087,7 @@ remove_id:
_("Failed to remove PCI ID '%s' from
%s"),
dev->id, driver);
- /* remove PCI ID from pci-stub failed, and we can not reprobe it */
+ /* remove PCI ID from pci-stub failed, and we cannot reprobe it */
if (dev->reprobe) {
VIR_WARN("Failed to remove PCI ID '%s' from %s, and the device
"
"cannot be probed again.", dev->id, driver);
I modify cfg.mk and update gnulib, use 'make syntax-check' and found the same
grammar
errors.
ACK.