The name is confusing, and the only use left is in a test case.
---
src/libvirt_private.syms | 1 -
src/util/virpci.c | 8 --------
src/util/virpci.h | 1 -
tests/virpcitest.c | 5 ++++-
4 files changed, 4 insertions(+), 11 deletions(-)
diff --git a/src/libvirt_private.syms b/src/libvirt_private.syms
index 83f6e2c..ab7b71d 100644
--- a/src/libvirt_private.syms
+++ b/src/libvirt_private.syms
@@ -1987,7 +1987,6 @@ virPCIDeviceListSteal;
virPCIDeviceListStealIndex;
virPCIDeviceNew;
virPCIDeviceReattach;
-virPCIDeviceReattachInit;
virPCIDeviceReset;
virPCIDeviceSetManaged;
virPCIDeviceSetRemoveSlot;
diff --git a/src/util/virpci.c b/src/util/virpci.c
index 505c1f3..f56dbe6 100644
--- a/src/util/virpci.c
+++ b/src/util/virpci.c
@@ -1771,14 +1771,6 @@ virPCIDeviceGetUsedBy(virPCIDevicePtr dev,
*dom_name = dev->used_by_domname;
}
-void virPCIDeviceReattachInit(virPCIDevicePtr pci)
-{
- pci->unbind_from_stub = true;
- pci->remove_slot = true;
- pci->reprobe = true;
-}
-
-
virPCIDeviceListPtr
virPCIDeviceListNew(void)
{
diff --git a/src/util/virpci.h b/src/util/virpci.h
index d1ac942..0debd7b 100644
--- a/src/util/virpci.h
+++ b/src/util/virpci.h
@@ -119,7 +119,6 @@ void virPCIDeviceSetRemoveSlot(virPCIDevice *dev,
unsigned int virPCIDeviceGetReprobe(virPCIDevicePtr dev);
void virPCIDeviceSetReprobe(virPCIDevice *dev,
bool reprobe);
-void virPCIDeviceReattachInit(virPCIDevice *dev);
virPCIDeviceListPtr virPCIDeviceListNew(void);
diff --git a/tests/virpcitest.c b/tests/virpcitest.c
index fb0c970..6dceef2 100644
--- a/tests/virpcitest.c
+++ b/tests/virpcitest.c
@@ -301,7 +301,10 @@ testVirPCIDeviceReattachSingle(const void *opaque)
if (!dev)
goto cleanup;
- virPCIDeviceReattachInit(dev);
+ virPCIDeviceSetUnbindFromStub(dev, true);
+ virPCIDeviceSetRemoveSlot(dev, true);
+ virPCIDeviceSetReprobe(dev, true);
+
if (virPCIDeviceReattach(dev, NULL, NULL) < 0)
goto cleanup;
--
2.5.0