On 10/21/20 10:46 AM, Matt Coleman wrote:
This set of patches adds several new APIs and fixes several others.
Changes since v2:
* adapted to all of Michal's recent changes
* enabled usage of g_autoptr for hypervInvokeParamsList
* avoid overwriting errors from hypervGetWmiClass()
* use switch statements instead of if for v1/v2 parameter differences
* added a helper function for domainReboot and domainReset
* removed translation for the shutdown reason
* changed the name of the constant for domainManagedSave on v2 to
reflect the wording in Microsoft's documentation
Matt Coleman (9):
hyperv: enable usage of g_autoptr for hypervInvokeParamsList
hyperv: avoid overwriting errors from hypervGetWmiClass()
hyperv: implement domainSetAutostart
hyperv: implement nodeGetFreeMemory
hyperv: implement domainReboot and domainReset
hyperv: implement domainShutdown and domainShutdownFlags
hyperv: fix domainSuspend and domainResume on Hyper-V V2
hyperv: fix domainManagedSave on Hyper-V V2
news: more Hyper-V APIs
NEWS.rst | 7 +-
src/hyperv/hyperv_driver.c | 353 ++++++++++++++++++++++----
src/hyperv/hyperv_wmi.h | 1 +
src/hyperv/hyperv_wmi_classes.h | 3 +
src/hyperv/hyperv_wmi_generator.input | 78 ++++++
5 files changed, 391 insertions(+), 51 deletions(-)
Patches look good. But please reply to my question in 5/9 so that I can
push.
Reviewed-by: Michal Privoznik <mprivozn(a)redhat.com>
Michal