
On 01/27/2016 12:39 PM, Andrea Bolognani wrote:
On Tue, 2016-01-26 at 18:56 -0500, John Ferlan wrote:
+/** + * virHostdevPCINodeDeviceReAttach:
^^ Oy ReAttach vs. Reattach is an eye test ;-)
Maybe we should standardize on either one or the other? I personally consider "ReAttach" to be quite an eyesore, but then again it's all over the public API so it's not going anywhere...
Sadly, I think we're stuck with that CaMel case because it's a driver function...
+ * @hostdev_mgr: hostdev manager + * @pci: PCI device
Perhaps better to indicate a "new"ly generated PCI device that does not track the internal reattach states and other state information such as the stub driver.
IOW: this is not a copy of an [in]activePCIHostdevs element
Great idea! Maybe even use a different name for the parameter, based on whether the virPCIDevicePtr is going to be used for something other than looking up the actual device?
This is I believe where I went back to patch 1 and started thinking about what is passed in 'pci'... Anything to help make things more obvious could be beneficial, especially considering what this code ends up doing... John
Cheers.
-- Andrea Bolognani Software Engineer - Virtualization Team