
On Tue, Oct 23, 2012 at 12:01:02PM -0600, Eric Blake wrote:
Commit 12ad7435 added new functions (virNodeGetMemoryParameters, virNodeSetMemoryParameters) into the section of the file reserved for deprecated names. Fix this by moving things earlier; split into two patches to make git diff easier to read.
* include/libvirt/libvirt.h.in: Move virTypedParameter earlier. --- include/libvirt/libvirt.h.in | 174 ++++++++++++++++++++++--------------------- 1 file changed, 88 insertions(+), 86 deletions(-)
I have to say I would dearly love to split up our header file into a number of pieces, since it is really a huge mess as it is. I'd like to have libvirt/virerror.h libvirt/virmisc.h libvirt/virconnect.h libvirt/virdomain.h libvirt/virnetwork.h libvirt/virnodedev.h libvirt/virinterface.h libvirt/..etc... In keeping with the way GTK works, applications would *not* include the individual header files directly - they'd simply continue to use libvirt.h as now, which would in turn #include all the individual pieces. Daniel -- |: http://berrange.com -o- http://www.flickr.com/photos/dberrange/ :| |: http://libvirt.org -o- http://virt-manager.org :| |: http://autobuild.org -o- http://search.cpan.org/~danberr/ :| |: http://entangle-photo.org -o- http://live.gnome.org/gtk-vnc :|