1. Fix typos caused by the renaming
2. It should substitute "remote/remote_protocol.h" to
"remote_protocol.h".
---
src/rpc/gendispatch.pl | 6 +++---
src/rpc/genprotocol.pl | 2 +-
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/src/rpc/gendispatch.pl b/src/rpc/gendispatch.pl
index c69c5a2..39d0ce6 100755
--- a/src/rpc/gendispatch.pl
+++ b/src/rpc/gendispatch.pl
@@ -9,8 +9,8 @@
# for both remote_protocol.x and qemu_protocol.x, you would run the
# following:
#
-# remote_generator.pl -c -t remote ../src/remote/remote_protocol.x
-# remote_generator.pl -t qemu ../src/remote/qemu_protocol.x
+# gendispatch.pl -c -t remote ../src/remote/remote_protocol.x
+# gendispatch.pl -t qemu ../src/remote/qemu_protocol.x
#
# By Richard Jones <rjones(a)redhat.com>
# Extended by Matthias Bolte <matthias.bolte(a)googlemail.com>
@@ -239,7 +239,7 @@ sub hyper_to_long
# Output
print <<__EOF__;
-/* Automatically generated by remote_generator.pl.
+/* Automatically generated by gendispatch.pl.
* Do not edit this file. Any changes you make will be lost.
*/
__EOF__
diff --git a/src/rpc/genprotocol.pl b/src/rpc/genprotocol.pl
index 4edba98..7124e5c 100755
--- a/src/rpc/genprotocol.pl
+++ b/src/rpc/genprotocol.pl
@@ -59,7 +59,7 @@ while (<RPCGEN>) {
s/xdr_u_quad_t/xdr_uint64_t/g;
s/xdr_quad_t/xdr_int64_t/g;
s/(?<!IXDR_GET_INT32 )IXDR_GET_LONG/IXDR_GET_INT32/g;
- s,#include "\./remote/remote_protocol\.h",#include
"remote_protocol.h",;
+ s,#include "remote/remote_protocol\.h",#include
"remote_protocol.h",;
if (m/^}/) {
$in_function = 0;
--
1.7.6