On 04/13/2015 06:19 AM, Peter Krempa wrote:
On Thu, Apr 02, 2015 at 13:39:42 -0400, John Ferlan wrote:
> Rather than have duplicate code doing the same check, have the netfs
> matching processing code use the new matchPoolSourceHost.
>
> Signed-off-by: John Ferlan <jferlan(a)redhat.com>
> ---
> src/conf/storage_conf.c | 5 ++---
> 1 file changed, 2 insertions(+), 3 deletions(-)
>
> diff --git a/src/conf/storage_conf.c b/src/conf/storage_conf.c
> index b3e930b..6ed0aa9 100644
> --- a/src/conf/storage_conf.c
> +++ b/src/conf/storage_conf.c
> @@ -2348,9 +2348,8 @@ virStoragePoolSourceFindDuplicate(virConnectPtr conn,
> matchpool = pool;
> break;
> case VIR_STORAGE_POOL_NETFS:
> - if ((STREQ(pool->def->source.dir, def->source.dir)) \
> - && (pool->def->source.nhost == 1 &&
def->source.nhost == 1) \
> - && (STREQ(pool->def->source.hosts[0].name,
def->source.hosts[0].name)))
> + if (STREQ(pool->def->source.dir, def->source.dir) &&
> + matchPoolSourceHost(&pool->def->source,
&def->source))
> matchpool = pool;
> break;
> case VIR_STORAGE_POOL_SCSI:
ACK, no semantic change. (But of course the patch will need a change
after renaming the function.
Right - I'll wait of course for your acceptance of the name I used and
adjust from there.
John