On 12/13/2012 02:06 AM, Guannan Ren wrote:
QEMU_CAPS_DEVICE_QXL -device qxl
QEMU_CAPS_DEVICE_VGA -device VGA
QEMU_CAPS_DEVICE_CIRRUS_VGA -device cirrus-vga
QEMU_CAPS_DEVICE_VMWARE_SVGA -device vmware-svga
QEMU_CAPS_1DOT20_PLUS /* safe to use -device XXX
for primary video device */
NACK to this name; see my complaints on the cover letter. We'll need a
v4 that picks a name more appropriate to the actual feature being
tested, rather than a name that merely reflects our current
implementation of why we decided the feature is available.
Hmm, maybe I misunderstood what the actual feature is when I suggested
QEMU_CAPS_SECONDARY_DISPLAY; based on the comment you used here, maybe a
better name is QEMU_CAPS_PRIMARY_DISPLAY_DEVICE.
+
+ "VGA", /* 120 */
+ "cirrus-vga",
+ "vmware-svga",
+ "qemu1.20+"
Again, this XML name does not reflect the feature; we need something nicer.
);
struct _qemuCaps {
@@ -1177,6 +1183,9 @@ qemuCapsComputeCmdFlags(const char *help,
if (version >= 11000)
qemuCapsSet(caps, QEMU_CAPS_CPU_HOST);
+
+ if (version >= 1002000)
+ qemuCapsSet(caps, QEMU_CAPS_1DOT20_PLUS);
return 0;
And here, what I envision if Red Hat decides to backport this feature
into their qemu 0.12.1.x monster, the Red Hat specific backport patch
would look like:
+
+ if (version >= 1002000)
+ qemuCapsSet(caps, QEMU_CAPS_PRIMARY_DISPLAY_DEVICE);
+#if BACKPORT_ONLY
+ else if (version is 12001 but feature is backported)
+ qemuCapsSet(caps, QEMU_CAPS_PRIMARY_DISPLAY_DEVICE);
+#endif
Remember, RHEL 6.x qemu will NOT be version 1.2 or later, it will stay
at version 0.12.1 + lots of backports.
--
Eric Blake eblake redhat com +1-919-301-3266
Libvirt virtualization library
http://libvirt.org