On Fri, 2019-02-08 at 17:11 -0500, Cole Robinson wrote:
[...]
+++ b/src/qemu/qemu_capabilities.h
@@ -505,6 +505,7 @@ typedef enum { /* virQEMUCapsFlags grouping marker for syntax-check
*/
QEMU_CAPS_OBJECT_MEMORY_FILE_PMEM, /* -object memory-backend-file,pmem= */
QEMU_CAPS_DEVICE_NVDIMM_UNARMED, /* -device nvdimm,unarmed= */
QEMU_CAPS_SCSI_DISK_DEVICE_ID, /* 'device_id' property of scsi disk */
+ QEMU_CAPS_VIRTIO_PCI_NON_TRANSITIONAL, /* virtio *-pci-{non-}transitional devices */
I realize I'm the one who suggested this name in the first place :/
but the "NON" part is... Not very useful when you think about it.
So we could just as well call this
QEMU_CAPS_VIRTIO_PCI_TRANSITIONAL
instead and save a few bytes.
Whether you feel like renaming it or not,
Reviewed-by: Andrea Bolognani <abologna(a)redhat.com>
--
Andrea Bolognani / Red Hat / Virtualization