v2 of:
https://www.redhat.com/archives/libvir-list/2016-August/msg00960.html
diff to v1:
- rename attribute to rx_queue_size
- added more documentation and test cases
- Other small nits John found
Michal Privoznik (3):
conf: Add support for virtio-net.rx_queue_size
qemu_capabilities: Introduce virtio-net-*.rx_queue_size
qemu: Implement virtio-net rx_queue_size
docs/formatdomain.html.in | 16 ++++++++-
docs/schemas/domaincommon.rng | 5 +++
src/conf/domain_conf.c | 16 +++++++++
src/conf/domain_conf.h | 1 +
src/qemu/qemu_capabilities.c | 3 ++
src/qemu/qemu_capabilities.h | 3 ++
src/qemu/qemu_command.c | 8 +++++
src/qemu/qemu_domain.c | 7 ++++
...ml2argv-net-virtio-rxqueuesize-invalid-size.xml | 29 +++++++++++++++
.../qemuxml2argv-net-virtio-rxqueuesize.args | 25 +++++++++++++
.../qemuxml2argv-net-virtio-rxqueuesize.xml | 29 +++++++++++++++
tests/qemuxml2argvtest.c | 3 ++
.../qemuxml2xmlout-net-virtio-rxqueuesize.xml | 41 ++++++++++++++++++++++
tests/qemuxml2xmltest.c | 1 +
14 files changed, 186 insertions(+), 1 deletion(-)
create mode 100644
tests/qemuxml2argvdata/qemuxml2argv-net-virtio-rxqueuesize-invalid-size.xml
create mode 100644 tests/qemuxml2argvdata/qemuxml2argv-net-virtio-rxqueuesize.args
create mode 100644 tests/qemuxml2argvdata/qemuxml2argv-net-virtio-rxqueuesize.xml
create mode 100644 tests/qemuxml2xmloutdata/qemuxml2xmlout-net-virtio-rxqueuesize.xml
--
2.8.4