Since the previous series (19 patches):
https://www.redhat.com/archives/libvir-list/2017-September/msg00594.html
didn't garner any attention, let me try with smaller patch piles with the
hope that forward progress will be made.
The only "new" one in this series from the other is patch2 - something
that Coverity let me know about in an error scenario.
Essentially the bulk of these patches remove direct obj->def referencing
in favor of a virStoragePoolObjGetDef call.
John Ferlan (6):
conf: Fix prototype/definition for virStoragePoolObj get functions
tests: Fix possible NULL deref
storage: Use virStoragePoolObjGetDef accessor for driver
test: Rename @vol to @volDef in testOpenVolumesForPool
test: Create local virStoragePoolObjPtr VolLookup APIs
test: Use virStoragePoolObjGetDef accessor
src/conf/virstorageobj.c | 4 +-
src/conf/virstorageobj.h | 4 +-
src/storage/storage_driver.c | 411 +++++++++++++++++++++++------------------
src/test/test_driver.c | 203 +++++++++++---------
tests/storagevolxml2argvtest.c | 3 +-
5 files changed, 352 insertions(+), 273 deletions(-)
--
2.13.6