On Tue, 2019-05-07 at 17:45 +0200, Martin Kletzander wrote:
@echo
@echo "Available make variables:"
@echo
+ @echo " CI_CENGINE=engine - container engine to use (podman (default) or
docker)"
@echo " CI_CLEAN=0 - do not delete '$(CI_SCRATCHDIR)' after
completion"
@echo " CI_REUSE=1 - re-use existing '$(CI_SCRATCHDIR)' content"
@echo
I have not looked at the code in detail, but I wanted to point this
out before you respin: I really don't like the name CI_CENGINE :)
Since we're dealing with containers exclusively I'm pretty sure we
can just go with CI_ENGINE and not cause any confusion for users.
The description given above is also not accurate, as far as I can
tell: we use Podman instead of Docker only if we detect that the
former is available, so what we really do is *prefer* Podman, not
default to it. I would document it along the lines of
CI_ENGINE=auto - container engine to use (podman, docker)
and implement it like
CI_ENGINE=auto
# ...
ifeq ($(CI_ENGINE),auto)
CI_ENGINE = $(shell ...)
endif
# Validate that CI_ENGINE is either podman or docker at this
# point, and error out otherwise
--
Andrea Bolognani / Red Hat / Virtualization