On Mon, Jun 13, 2016 at 20:27:45 -0400, John Ferlan wrote:
Move to virsecret.c and rename to virSecretParseSecret. Also convert
to
NACK to the naming. It implies that it parses <secret> xmls.
usage xmlNodePtr and virXMLPropString rather than virXPathString.
Signed-off-by: John Ferlan <jferlan(a)redhat.com>
---
po/POTFILES.in | 1 +
src/libvirt_private.syms | 1 +
src/util/virsecret.c | 44 +++++++++++++++++++++++++++++
src/util/virsecret.h | 5 +++-
src/util/virstoragefile.c | 71 ++++++++++++-----------------------------------
5 files changed, 67 insertions(+), 55 deletions(-)
diff --git a/src/libvirt_private.syms b/src/libvirt_private.syms
index 32d5179..ca65885 100644
--- a/src/libvirt_private.syms
+++ b/src/libvirt_private.syms
@@ -2211,6 +2211,7 @@ virSecurityLabelDefNew;
# util/virsecret.h
virSecretLookupDefClear;
virSecretLookupDefCopy;
+virSecretParseSecret;
It should be named similarly to the above or to the original name.
ACK to the code as long as you name it reasonably