On Fri, Jun 19, 2020 at 10:32:43 +0100, Daniel Berrange wrote:
We can't change the term used by scsi_id for its CLI arg, but
we can avoid it by picking the short form instead.
Signed-off-by: Daniel P. Berrangé <berrange(a)redhat.com>
---
src/util/virstoragefile.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/util/virstoragefile.c b/src/util/virstoragefile.c
index a6357abb08..b4337c2736 100644
--- a/src/util/virstoragefile.c
+++ b/src/util/virstoragefile.c
@@ -1365,7 +1365,7 @@ virStorageFileGetSCSIKey(const char *path,
cmd = virCommandNewArgList("/lib/udev/scsi_id",
"--replace-whitespace",
- "--whitelisted",
+ "-g",
IMO this decreases the readability of the code.