
John Ferlan <jferlan@redhat.com> [2017-05-19, 09:08AM -0400]:
Move the whole file from src/node_device into src/conf and rename the API's to have the "virNodeDevice" prefix.
Signed-off-by: John Ferlan <jferlan@redhat.com> --- src/Makefile.am | 8 ++++---- .../node_device_linux_sysfs.c | 24 ++++++++++------------ .../node_device_linux_sysfs.h | 9 +++++--- src/libvirt_private.syms | 5 +++++ src/node_device/node_device_driver.c | 8 ++++---- src/node_device/node_device_hal.c | 4 ++-- src/node_device/node_device_udev.c | 4 ++-- 7 files changed, 34 insertions(+), 28 deletions(-) rename src/{node_device => conf}/node_device_linux_sysfs.c (89%) rename src/{node_device => conf}/node_device_linux_sysfs.h (82%)
What's the reasoning for this move? It somehow doesn't feel right and it will make backports harder.