On 11/20/2015 10:22 AM, Peter Krempa wrote:
---
src/conf/domain_audit.c | 2 +-
src/conf/domain_conf.c | 19 +++++++++++++------
src/conf/domain_conf.h | 1 +
src/libvirt_private.syms | 1 +
src/libxl/libxl_conf.c | 2 +-
src/libxl/libxl_driver.c | 8 ++++----
src/lxc/lxc_controller.c | 2 +-
src/lxc/lxc_driver.c | 2 +-
src/openvz/openvz_driver.c | 2 +-
src/phyp/phyp_driver.c | 5 +++--
src/qemu/qemu_command.c | 2 +-
src/qemu/qemu_driver.c | 36 ++++++++++++++++++------------------
src/qemu/qemu_process.c | 10 +++++-----
src/test/test_driver.c | 14 +++++++-------
src/uml/uml_driver.c | 2 +-
src/vmware/vmware_driver.c | 2 +-
src/vmx/vmx.c | 14 ++++++++------
src/xen/xm_internal.c | 4 ++--
src/xenapi/xenapi_utils.c | 2 +-
src/xenconfig/xen_common.c | 3 ++-
src/xenconfig/xen_sxpr.c | 5 +++--
21 files changed, 76 insertions(+), 62 deletions(-)
Again change the name from "VCpus" to "Vcpus" (or "VCPUs")
Using cscope - after this patch the following still access ->vcpus
virBhyveProcessBuildBhyveCmd
bhyveDomainGetInfo
virDomainDefSetVCpusMax
virDomainDefHasVCpusOffline
vzDomainGetInfo (twice)
vzDomainGetVcpusFlags
prlsdkCheckUnsupportedParams
prlsdkDoApplyConfig
Here too I'll try to remember to flag non accessor changes if I see them
in future patches (although I suspect adjustment there could be ugly).
Similar to comment earlier out maxvcpus, if there were some syntax-check
rule that could be added (outside of domain_conf.c) - that would be great.
ACK w/ the name adjustment and use of accessor in listed functions
John