On 9/15/21 1:07 PM, Kristina Hanicova wrote:
This is v2 of:
https://listman.redhat.com/archives/libvir-list/2021-August/msg00871.html
diff to v1:
- rebased onto the current master
- changed the way of working with flags to make the code more readable
(suggested by Jano and Daniel). I added a comment in one case when it
was not possible without further refactoring of more functions.
Kristina Hanicova (5):
api: add public virNetworkCreateXMLFlags() and remote protocol
src: add driver support for networkCreateXMLFlags()
api: add virNetworkCreateFlags
network: allow VIR_NETWORK_CREATE_VALIDATE flag
virsh: add support for '--validate' option in create network
docs/manpages/virsh.rst | 4 ++-
include/libvirt/libvirt-network.h | 7 ++++++
src/driver-network.h | 6 +++++
src/libvirt-network.c | 41 +++++++++++++++++++++++++++++++
src/libvirt_public.syms | 1 +
src/network/bridge_driver.c | 21 +++++++++++++---
src/remote/remote_driver.c | 1 +
src/remote/remote_protocol.x | 18 +++++++++++++-
src/remote_protocol-structs | 8 ++++++
src/test/test_driver.c | 16 ++++++++++--
src/vbox/vbox_network.c | 13 +++++++++-
tools/virsh-network.c | 13 +++++++++-
12 files changed, 139 insertions(+), 10 deletions(-)
Reviewed-by: Michal Privoznik <mprivozn(a)redhat.com>
Michal