On 10/15/19 4:44 AM, Kevin Wolf wrote:
Am 14.10.2019 um 20:10 hat John Snow geschrieben:
>
>
> On 10/11/19 7:18 PM, John Snow wrote:
>>
>>
>> On 10/11/19 5:48 PM, Eric Blake wrote:
>>> On 10/11/19 4:25 PM, John Snow wrote:
>>>> From: Vladimir Sementsov-Ogievskiy <vsementsov(a)virtuozzo.com>
>>>>
>>>> hbitmap_reset has an unobvious property: it rounds requested region up.
>>>> It may provoke bugs, like in recently fixed write-blocking mode of
>>>> mirror: user calls reset on unaligned region, not keeping in mind that
>>>> there are possible unrelated dirty bytes, covered by rounded-up region
>>>> and information of this unrelated "dirtiness" will be lost.
>>>>
>>>> Make hbitmap_reset strict: assert that arguments are aligned, allowing
>>>> only one exception when @start + @count == hb->orig_size. It's
needed
>>>> to comfort users of hbitmap_next_dirty_area, which cares about
>>>> hb->orig_size.
>>>>
>>>> Signed-off-by: Vladimir Sementsov-Ogievskiy
<vsementsov(a)virtuozzo.com>
>>>> Reviewed-by: Max Reitz <mreitz(a)redhat.com>
>>>> Message-Id: <20190806152611.280389-1-vsementsov(a)virtuozzo.com>
>>>> [Maintainer edit: Max's suggestions from on-list. --js]
>>>> Signed-off-by: John Snow <jsnow(a)redhat.com>
>>>> ---
>>>> include/qemu/hbitmap.h | 5 +++++
>>>> tests/test-hbitmap.c | 2 +-
>>>> util/hbitmap.c | 4 ++++
>>>> 3 files changed, 10 insertions(+), 1 deletion(-)
>>>>
>>>
>>>> +++ b/util/hbitmap.c
>>>> @@ -476,6 +476,10 @@ void hbitmap_reset(HBitmap *hb, uint64_t start,
>>>> uint64_t count)
>>>> /* Compute range in the last layer. */
>>>> uint64_t first;
>>>> uint64_t last = start + count - 1;
>>>> + uint64_t gran = 1ULL << hb->granularity;
>>>> +
>>>> + assert(!(start & (gran - 1)));
>>>> + assert(!(count & (gran - 1)) || (start + count ==
hb->orig_size));
>>>
>>> I know I'm replying a bit late (since this is now a pull request), but
>>> would it be worth using the dedicated macro:
>>>
>>> assert(QEMU_IS_ALIGNED(start, gran));
>>> assert(QEMU_IS_ALIGNED(count, gran) || start + count == hb->orig_size);
>>>
>>> instead of open-coding it? (I would also drop the extra () around the
>>> right half of ||). If we want it, that would now be a followup patch.
>
> I've noticed that seasoned C programmers hate extra parentheses a lot.
> I've noticed that I cannot remember operator precedence enough to ever
> feel like this is actually an improvement.
>
> Something about a nice weighted tree of ((expr1) || (expr2)) feels
> soothing to my weary eyes. So, if it's not terribly important, I'd
> prefer to leave it as-is.
I don't mind the parentheses, but I do prefer QEMU_IS_ALIGNED() to the
open-coded version. Would that be a viable compromise?
Oh, I'm sorry! I did change that. I didn't mean to appear any more
stubborn than I actually am.
--js