On Mon, Jun 13, 2016 at 20:27:44 -0400, John Ferlan wrote:
Move the enum into a new src/util/virsecret.h, rename it to be
virSecretLookupType. Add a src/util/virsecret.h in order to perform
a couple of simple operations on the secret XML and virSecretLookupTypeDef
for clearing and copying.
This includes quite a bit of collateral damage, but the goal is to remove
the "virStorage*" and replace with the virSecretLookupType so that it's
easier to to add new lookups that aren't necessarily storage pool related.
Signed-off-by: John Ferlan <jferlan(a)redhat.com>
---
src/Makefile.am | 1 +
src/conf/secret_conf.h | 2 +-
src/libvirt_private.syms | 5 ++++
src/libxl/libxl_conf.c | 2 +-
src/qemu/qemu_domain.c | 4 +--
src/secret/secret_util.c | 18 ++++++------
src/secret/secret_util.h | 10 +++----
src/storage/storage_backend_iscsi.c | 7 +++--
src/storage/storage_backend_rbd.c | 3 +-
src/util/virsecret.c | 57 +++++++++++++++++++++++++++++++++++++
src/util/virsecret.h | 50 ++++++++++++++++++++++++++++++++
src/util/virstoragefile.c | 32 +++++++++------------
src/util/virstoragefile.h | 17 ++---------
tests/qemuargv2xmltest.c | 4 +--
14 files changed, 156 insertions(+), 56 deletions(-)
create mode 100644 src/util/virsecret.c
create mode 100644 src/util/virsecret.h
ACK