On 10/08/2012 02:37 PM, Marcelo Cerri wrote:
This patch series moves the logic for parsing users and groups in a
similar way to coreutils' chown from security_dac.c to util.c, as
suggested by Eric Blake.
This change has two majors side effects:
1. Some error messages that were issued when security_dac.c tried to
parse an ID as a name are no longer issued.
2. The keys `user` and `group` in qemu.conf can now be defined in the
same way that in DAC security labels.
Peter Krempa's fix for correctly handling errors returned by getpwnam_r and
getgrnam_r is squashed into this patch series.
Marcelo Cerri (2):
util: extend virGetUserID and virGetGroupID to support names and IDs
security: update user and group parsing in security_dac.c
src/security/security_dac.c | 45 +++-----------
src/util/util.c | 143 ++++++++++++++++++++++++++++++++------------
2 files changed, 112 insertions(+), 76 deletions(-)
ACK series, and pushed. However, I wonder if we should prepare a
followup patch to src/qemu/qemu.conf, documenting the new semantics of
the 'user' and 'group' config items for accepting numeric ids via
leading '+' in the string.
--
Eric Blake eblake(a)redhat.com +1-919-301-3266
Libvirt virtualization library
http://libvirt.org