On Tue, Jan 23, 2018 at 09:48:51AM +0000, Daniel P. Berrange wrote:
On Mon, Jan 22, 2018 at 06:15:59PM +0100, Pavel Hrdina wrote:
> Signed-off-by: Pavel Hrdina <phrdina(a)redhat.com>
> ---
> src/util.h | 2 ++
> 1 file changed, 2 insertions(+)
>
> diff --git a/src/util.h b/src/util.h
> index 0c9f3d7..6d99841 100644
> --- a/src/util.h
> +++ b/src/util.h
> @@ -8,6 +8,8 @@
> #define _cleanup_(_x) __attribute__((__cleanup__(_x)))
> #define VIR_ATTR_UNUSED __attribute__((__unused__))
>
> +#define VIRT_ARRAY_CARDINALITY(array) (sizeof(array) / sizeof(*(array)))
> +
>
> int
> virtDBusUtilMessageAppendTypedParameters(sd_bus_message *message,
Reviewed-by: Daniel P. Berrange <berrange(a)redhat.com>
Though if I was naming this again in libvirt I would follow glib and call
it VIR_N_ELEMENTS as it way shorter & easier to spell than the word
CARDINALITY :-) Your call !
That's definitely better name, I'll use that one, thanks.
Pavel