?Okay, I'll make the change... Currently at naming level, my problem is
around Error class. Do you have a suggestion ?
--------------------------------------------------
From: "Daniel P. Berrange" <berrange(a)redhat.com>
Sent: Wednesday, October 20, 2010 2:01 PM
To: <arnaud.champion(a)devatom.fr>
Cc: <libvir-list(a)redhat.com>
Subject: Re: [libvirt] [PATCH] C#Bindings patch, rename classes
On Wed, Oct 20, 2010 at 01:44:56PM +0200, arnaud.champion(a)devatom.fr
wrote:
> ?Hi,
>
> here is a new patch. It propose to separate types of function by classes.
> For example :
>
> all virConnect[*] (virConnectOpen, virConnectNumOfDomains, etc...)
> functions are in the virConnect class.
> all virDomain[*] (virDomainCreate, virDomainDestroy, etc...) function are
> in the virDomain class.
>
> so we have these classes now :
>
> virConnect
> virDomain
> virEvent
> virInterface
> virLibrary
> virNetwork
> virNode
> virSecret
> virStoragePool
> virStorageVol
> virStream
IMHO
namespace LibvirtBindings
{
public class virDomain
{
....
Is somewhat redundant and better named
namespace Libvirt
{
public class Domain
{
....
The 'vir' prefix on C library APIs/structs is just a hack because C
does not have any concept of namespaces. It shouldn't be copied into
languages which do have proper namespace support
Regards,
Daniel
--
|: Red Hat, Engineering, London -o-
http://people.redhat.com/berrange/ :|
|:
http://libvirt.org -o-
http://virt-manager.org -o-
http://deltacloud.org :|
|:
http://autobuild.org -o-
http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505 -o- F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B
9505 :|