On Tue, Apr 02, 2019 at 09:35:36 +0200, Ján Tomko wrote:
On Fri, Mar 22, 2019 at 07:00:51PM +0100, Peter Krempa wrote:
> virDomainDiskSourceParse was now just a thin wrapper without any extra
> value. Replace all usage of it by the function it calls and remove the
> function.
>
> Signed-off-by: Peter Krempa <pkrempa(a)redhat.com>
> ---
> src/conf/domain_conf.c | 22 ++++------------------
> src/conf/domain_conf.h | 5 -----
> src/conf/snapshot_conf.c | 2 +-
> tests/qemublocktest.c | 2 +-
> 4 files changed, 6 insertions(+), 25 deletions(-)
>
> diff --git a/src/conf/domain_conf.c b/src/conf/domain_conf.c
> index fa50b6f000..c93c4df929 100644
> --- a/src/conf/domain_conf.c
> +++ b/src/conf/domain_conf.c
> @@ -9186,7 +9172,7 @@ virDomainDiskBackingStoreParse(xmlXPathContextPtr ctxt,
> return -1;
> }
>
> - if (virDomainDiskSourceParse(source, ctxt, backingStore, flags, xmlopt) < 0
||
> + if (virDomainStorageSourceParse(source, ctxt, backingStore, flags, xmlopt) <
0 ||
Hmm, so we have virDomainStorageSourceParse and a corresponding
virDomainDiskSourceFormat?
Maybe the previous commit dropped the wrong function.
Should I rename virDomainDiskSourceFormat to virDomainStorageSourceFormat
in an upcomming patch?
> virDomainDiskBackingStoreParse(ctxt, backingStore, flags, xmlopt) < 0)
> return -1;
>
Reviewed-by: Ján Tomko <jtomko(a)redhat.com>
Jano
--
libvir-list mailing list
libvir-list(a)redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list