Eric Blake wrote:
According to David Allan on 3/2/2010 3:13 PM:
> ---
> tools/virsh.c | 42 ++++++++++++++++++++++++++++++++++++++++++
> 1 files changed, 42 insertions(+), 0 deletions(-)
>
> diff --git a/tools/virsh.c b/tools/virsh.c
> index a6a637d..e52b011 100644
> --- a/tools/virsh.c
> +++ b/tools/virsh.c
> @@ -5221,6 +5221,47 @@ cmdVolDelete(vshControl *ctl, const vshCmd *cmd)
>
>
> /*
> + * "vol-zero-out" command
> + */
> +static const vshCmdInfo info_vol_zero_out[] = {
> + {"help", gettext_noop("zero out a vol")},
> + {"desc", gettext_noop("Ensure further reads from a volume return
zeroes.")},
Unrelated to your patch, but is there any reason we don't use N_() as the
idiomatic counterpart to _(), rather than spelling out gettext_noop
everywhere?
That'd be a fine change, because it'd shorten some lines,
making things slightly more readable.
Plus, with 440 occurrences, it'd decrease the size of virsh.c by over 4 KB ;-)