On Mon, Dec 02, 2013 at 02:47:59PM +0800, Gao feng wrote:
This patch introduces new xml elements under <blkiotune>,
we use these new elements to setup the throttle blkio
cgroup for domain. The new blkiotune node looks like this:
<blkiotune>
<device>
<path>/path/to/block</path>
<weight>1000</weight>
<read_iops>10000</read_iops>
<write_iops>10000</write_iops>
<read_bps>10000</read_bps>
<write_bps>10000</write_bps>
</device>
</blkiotune>
Under the <disk> element we have
<iotune>
<total_bytes_sec>10000000</total_bytes_sec>
<read_iops_sec>400000</read_iops_sec>
<write_iops_sec>100000</write_iops_sec>
</iotune>
Please use a consistent naming convention for these new
elements - ie read_iops_sec not read_iops.
Daniel
--
|:
http://berrange.com -o-
http://www.flickr.com/photos/dberrange/ :|
|:
http://libvirt.org -o-
http://virt-manager.org :|
|:
http://autobuild.org -o-
http://search.cpan.org/~danberr/ :|
|:
http://entangle-photo.org -o-
http://live.gnome.org/gtk-vnc :|