On 06/21/2016 10:05 AM, Peter Krempa wrote:
On Mon, Jun 13, 2016 at 20:27:45 -0400, John Ferlan wrote:
> Move to virsecret.c and rename to virSecretParseSecret. Also convert to
NACK to the naming. It implies that it parses <secret> xmls.
The "Secret" just replaced the "StorageAuthDef" since no longer was a
<secret> going to be only an element of <auth>.
> usage xmlNodePtr and virXMLPropString rather than
virXPathString.
>
> Signed-off-by: John Ferlan <jferlan(a)redhat.com>
> ---
> po/POTFILES.in | 1 +
> src/libvirt_private.syms | 1 +
> src/util/virsecret.c | 44 +++++++++++++++++++++++++++++
> src/util/virsecret.h | 5 +++-
> src/util/virstoragefile.c | 71 ++++++++++++-----------------------------------
> 5 files changed, 67 insertions(+), 55 deletions(-)
>
> diff --git a/src/libvirt_private.syms b/src/libvirt_private.syms
> index 32d5179..ca65885 100644
> --- a/src/libvirt_private.syms
> +++ b/src/libvirt_private.syms
> @@ -2211,6 +2211,7 @@ virSecurityLabelDefNew;
> # util/virsecret.h
> virSecretLookupDefClear;
> virSecretLookupDefCopy;
> +virSecretParseSecret;
It should be named similarly to the above or to the original name.
ACK to the code as long as you name it reasonably
OK - is virSecretLookupParseSecret more palatable? Or an even longer
name virSecretLookupParseDomainSecret.
Up through this point it's only a subelement of <auth>, but adding to
<encryption> short term and to <serial> for TLS secrets in another series.
Also, As I was working in the TLS code - I began to realize using
'secdef' for variable names became confusing, so I changed to
'seclookupdef'... That was posted as a separate series
I also note that patch 5 doesn't yet have any review, but this patch
relies on that.
Tks -
John