On 05/23/2011 09:16 AM, Alon Levy wrote:
This adds a streaming-video=filter|all|off attribute. It is used to
change
the behavior of video stream detection in spice, the default is filter (the
default for libvirt is not to specify it - the actual default is defined in
libspice-server.so).
Usage:
<graphics type='spice' autoport='yes'>
<streaming mode='off'/>
</graphics>
Tested with the above and with tests/qemuxml2argvtest.
Signed-off-by: Alon Levy <alevy(a)redhat.com>
@@ -1816,6 +1817,11 @@ qemu-kvm -net nic,model=? /dev/null
and <code>playback</code> for enabling audio stream
compression (accepts <code>on</code> or
<code>off</code>).
</p>
+ <p>
+ Streaming mode is set by the <code>streaming</code>
+ element, settings it's <code>mode</code> attribute to one
+ of <code>filter</code>,<code>all</code> or
<code>off</code>.
s/,<code/, <code/
+ </p>
I added a "since 0.9.2" notation here.
@@ -8067,6 +8094,9 @@ virDomainGraphicsDefFormat(virBufferPtr buf,
if (def->data.spice.playback)
virBufferAsprintf(buf, " <playback
compression='%s'/>\n",
virDomainGraphicsSpicePlaybackCompressionTypeToString(def->data.spice.playback));
+ if (def->data.spice.streaming)
+ virBufferVSprintf(buf, " <streaming
mode='%s'/>\n",
+
virDomainGraphicsSpiceStreamingModeTypeToString(def->data.spice.streaming));
We changed the name from virBufferVSprintf to virBufferAsprintf a few
patches ago. The joys of rebasing. Also affects qemu_command.c.
@@ -276,6 +276,8 @@
virDomainGraphicsSpicePlaybackCompressionTypeFromString;
virDomainGraphicsSpicePlaybackCompressionTypeToString;
virDomainGraphicsSpiceZlibCompressionTypeFromString;
virDomainGraphicsSpiceZlibCompressionTypeToString;
+virDomainGraphicsSpiceStreamingModeTypeFromString;
+virDomainGraphicsSpiceStreamingModeTypeToString;
I sorted these.
ACK with those nits fixed, and pushed.
--
Eric Blake eblake(a)redhat.com +1-801-349-2682
Libvirt virtualization library
http://libvirt.org