changes from v1 [1], all suggested by Ján Tomko:
- qemu patch (former patch 10):
* qemu_driver.c: using 'return -1' instead of 'return ret' in
qemuDumpToFd()
and qemuDomainBlockPivot()
* qemu_hotplug.c: removed the use of 'ret' variable in
qemuDomainChangeGraphics(), returning -1 in all error
conditions and returning 0 in the end
- vbox patch (former patch 13):
* vbox_common.c: changed 'return -2' to 'return -1' in
vboxDomainGetInfo()
- tests patch (former patch 20):
* domainconftest.c: rolled back the change since the 'goto cleanup'
is more readable than copying EXIT_SUCCESS multiple times.
[1]
https://www.redhat.com/archives/libvir-list/2019-October/msg01420.html
Daniel Henrique Barboza (3):
qemu: remove unneeded cleanup labels
vbox: remove unneeded cleanup labels
tests: remove unneeded cleanup labels
src/qemu/qemu_cgroup.c | 15 ++--
src/qemu/qemu_domain.c | 84 ++++++------------
src/qemu/qemu_domain_address.c | 31 +++----
src/qemu/qemu_driver.c | 145 +++++++++++--------------------
src/qemu/qemu_hotplug.c | 75 +++++++---------
src/qemu/qemu_interface.c | 26 +++---
src/qemu/qemu_migration.c | 38 +++-----
src/qemu/qemu_process.c | 69 +++++----------
src/qemu/qemu_tpm.c | 18 ++--
src/vbox/vbox_common.c | 12 ++-
src/vbox/vbox_snapshot_conf.c | 75 +++++++---------
tests/commandtest.c | 17 ++--
tests/networkxml2firewalltest.c | 10 +--
tests/nsstest.c | 27 +++---
tests/nwfilterebiptablestest.c | 4 +-
tests/nwfilterxml2firewalltest.c | 16 ++--
tests/qemuhotplugtest.c | 19 ++--
tests/qemuxml2argvtest.c | 11 +--
tests/virauthconfigtest.c | 11 +--
tests/vircgroupmock.c | 11 +--
tests/virendiantest.c | 58 ++++++-------
tests/virkeycodetest.c | 14 +--
tests/virmacmaptest.c | 5 +-
tests/virnetdevtest.c | 11 +--
tests/virpcimock.c | 31 +++----
tests/virpcitest.c | 3 +-
tests/virpolkittest.c | 65 +++++---------
tests/virstringtest.c | 18 ++--
28 files changed, 333 insertions(+), 586 deletions(-)
--
2.21.0