On 1/28/22 08:35, huangy81(a)chinatelecom.cn wrote:
From: Hyman Huang(黄勇) <huangy81(a)chinatelecom.cn>
Add mode parameter to qemuDomainStartDirtyRateCalc API, 'mode'
option of 'calc-dirty-rate' command was introduced since
qemu >= 6.2.
Signed-off-by: Hyman Huang(黄勇) <huangy81(a)chinatelecom.cn>
---
src/qemu/qemu_driver.c | 4 +++-
src/qemu/qemu_monitor.c | 5 +++--
src/qemu/qemu_monitor.h | 3 ++-
src/qemu/qemu_monitor_json.c | 17 +++++++++++++++--
src/qemu/qemu_monitor_json.h | 3 ++-
5 files changed, 25 insertions(+), 7 deletions(-)
diff --git a/src/qemu/qemu_driver.c b/src/qemu/qemu_driver.c
index c8ee897..cb2af61 100644
--- a/src/qemu/qemu_driver.c
+++ b/src/qemu/qemu_driver.c
@@ -20647,6 +20647,8 @@ qemuDomainStartDirtyRateCalc(virDomainPtr dom,
virQEMUDriver *driver = dom->conn->privateData;
virDomainObj *vm = NULL;
qemuDomainObjPrivate *priv;
+ virDomainDirtyRateCalcMode mode =
+ VIR_DOMAIN_DIRTYRATE_CALC_MODE_PAGE_SAMPLING;
It's okay if this is all on one line. It's more readable that way
anyway. The limit for 80 characters is more of a recommendation and due
to way we construct names it's easy to reach pretty soon. The aim of the
rule is to make code more readable. And I find it more readable when on
one line. Therefore, in this particular example it's okay of the line is
longer.
Michal